System Requirements requires the following minimum browser versions:

  • Internet Explorer 5.5 SP2
  • Netscape 6.0

NOTE: FireFox, Seamonkey (Mozilla), Opera, Safari, and Camino are also compatible.


Internet security software may prevent your browser from working properly with

If you expierence problems and use
Shaw Secure, XpressSecure, or F-Secure, click here for instructions on how to enable your browser.

  Book Online | Products | System Requirements | Privacy Policy | About Us | Contact Us
  ©2006 Telenium Inc. All rights reserved.